My CGI/ASP/PHP script is giving an error when trying to write to a file.

This applies to Linux hosting accounts only.

This is almost certainly down to incorrect permissions on your script or file. Please see the following information on how to set permissions on files:

Doing a CHMOD (changing a file's permissions) is the setting of access privileges for a file. This tutorial shows the process in one of the most common FTP applications called WS_FTP but the process is very similar with other ftp clients. Only Perl scripts need to have permissions changed to run.

First connect to your hosting via FTP using the settings provided in your setup email. Click on the "public_html" directory to open the area where your website is placed.

Next click on the directory and right-click on the file you would like to set permissions for. The right-click menu is then displayed, and by clicking the "CHMOD" option we get to the main part of doing a CHMOD.

The new menu that appears has three columns - Owner, Group, and Other. Each column has three checkboxes below them - Read, Write, and Execute. In the "Owner" column, check all three boxes. In the "Group" column check the first and third checkboxes. In the "Other" column, check the first and third boxes.

Finally, click "OK" to complete the CHMOD. Test your script again by calling it from your web browser. Everything should work correctly, but if you are still seeing an Error 500 Server Error then it is not because of your permissions but more the coding within the script itself. 

  • Email, SSL
  • 0 Users Found This Useful
Was this answer helpful?

Related Articles

When I try and view my website I get an HTTP Error 403 - Forbidden message.

A '403 Forbidden' message means that the browser has requested a page that it is not permitted to...

When I try and view my website I get an HTTP Error 403 - Forbidden message.

A '403 Forbidden' message means that the browser has requested a page that it is not permitted to...

My links are not working. What is wrong?

First of all, check that the link is correctly spelled, and that the correct case is used -...

My links are not working. What is wrong?

First of all, check that the link is correctly spelled, and that the correct case is used -...

I've put up my site but I still see the standard index page. What's up?

When we create a hosting package, we place a simple index.html holding page into the public_html...

Powered by WHMCompleteSolution